Can't CAST data in Impala SQL Editor

I have a large data set made up of timestamps , but when I try to load the document with the data type set to “timestamp,” the results come back as “NULL,” so I converted them to decimal values in Excel and figured I would transform them into timestamps once I had the document up in Impala. When I loaded the Text file with the datatype set to “double,” the data set populated fine, but when I went to the Editor and tried to use CAST to change the decimal values into timestamps, I got an error message that seems to indicate that the Editor doesn’t recognize CAST as a viable command.

The documentation indicates that I can use CAST, but that clearly isn’t working out very well. Has anyone else encountered this problem, or does anyone know what I might try as a workaround?

Instead of CAST, have you tried with FROM_UNIXTIME?


select from_unixtime(1501083119,"yyyy-MM-dd HH:mm:ss")

Thank you very much for the suggestion, but when I tried running it, I got this error:

AnalysisException: No matching function with signature: from_unixtime(DECIMAL(10,9), STRING).