Error: command 'arm-linux-gnueabihf-gcc' failed with exit status 1

Hi all,

I am trying for a while to manually install hue on my raspberry pi 4 (w/ raspian buster SO) but now I am getting this error:

building ‘Crypto.PublicKey._fastmath’ extension
creating build/temp.linux-armv7l-2.7
creating build/temp.linux-armv7l-2.7/src
arm-linux-gnueabihf-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -fdebug-prefix-map=/build/python2.7-9NJ3qw/python2.7-2.7.16=. -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/ -I/usr/include/python2.7 -c src/_fastmath.c -o build/temp.linux-armv7l-2.7/src/_fastmath.o
src/_fastmath.c:36:11: fatal error: gmp.h: No such file or directory

include <gmp.h>


compilation terminated.
error: command ‘arm-linux-gnueabihf-gcc’ failed with exit status 1
make[2]: *** [/home/pi/hue/Makefile.sdk:121: /home/pi/hue/desktop/core/build/pycrypto-2.6.1/egg.stamp] Error 1
make[2]: Leaving directory ‘/home/pi/hue/desktop/core’
make[1]: *** [Makefile:107: .recursive-env-install/core] Error 2
make[1]: Leaving directory ‘/home/pi/hue/desktop’
make: *** [Makefile:148: desktop] Error 2

To be honest I’ve tried many things like to install the arm-linux-gnueabihf-gcc that’s working as you can see below:
$ arm-linux-gnueabihf-gcc -v
Using built-in specs.
Target: arm-linux-gnueabihf
Configured with: …/src/configure -v --with-pkgversion=‘Raspbian 8.3.0-6+rpi1’ --with-bugurl=file:///usr/share/doc/gcc-8/README.Bugs --enable-languages=c,ada,c++,go,d,fortran,objc,obj-c++ --prefix=/usr --with-gcc-major-version-only --program-suffix=-8 --program-prefix=arm-linux-gnueabihf- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --enable-bootstrap --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-libitm --disable-libquadmath --disable-libquadmath-support --enable-plugin --with-system-zlib --with-target-system-zlib --enable-objc-gc=auto --enable-multiarch --disable-sjlj-exceptions --with-arch=armv6 --with-fpu=vfp --with-float=hard --disable-werror --enable-checking=release --build=arm-linux-gnueabihf --host=arm-linux-gnueabihf --target=arm-linux-gnueabihf
Thread model: posix
gcc version 8.3.0 (Raspbian 8.3.0-6+rpi1)

And I also have tried to change the hue version, where I’ve started using the version 4.0 and then I’ve changed to the version cdh5-3.9.0_5.14.0, but the error is the same.

I don’t need hue, because I have already everything installed (I mean the hadoop/spark installation), but I would like to have it on my cluster as well., but I couldn’t imagine that it should be so painful.

Does anyone know this problem?


missing hints that the equivalent of “gmp-devel” package is missing (