Presto Integration with Hue

I am deploying Hue-4.4.
I wanted to know that, if currently Hue supports connector to presto ?

There are some connectors

Hi Romain,

Thanks for the link.

As per the link. I can see that presto connector is available.
When I tried to add the configuration in hue.ini and re run HUE.
On clicking the Editor -> Presto button I am getting the following error.

An error occurred while calling z:java.sql.DriverManager.getConnection. : java.sql.SQLException: Authentication using username/password requires SSL to be enabled at com.facebook.presto.jdbc.PrestoDriverUri.setupClient( at com.facebook.presto.jdbc.PrestoDriver.connect( at java.sql.DriverManager.getConnection( at java.sql.DriverManager.getConnection( at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) …l.invoke( at java.lang.reflect.Method.invoke( at py4j.reflection.MethodInvoker.invoke( at py4j.reflection.ReflectionEngine.invoke( at py4j.Gateway.invoke( at py4j.commands.AbstractCommand.invokeMethod( at py4j.commands.CallCommand.execute( at at

It is asking for SSL to be enabled. But I don’t want to user SSL.
Is there a way to integrate presto in Hue with SSL being disabled?

Thanks Again.

Could you use the SqlAlchemy interface and not JDBC?

This is the most used one:

The dialect should be added to the Python system or Hue Python virtual environment:

  ./build/env/bin/pip install pyhive

Then give Hue the information about the database source:

   name = Presto
   options='{"url": "presto://localhost:8080/hive/default"}'

@Romain i used SqlAlchemy interface , but when i am running query in presto editor its running the query as the user by which hue is running and not as end user.
Hence i am getting permission issues on hdfs.

am i missing anything?


I see, I guess we would need to patch the sqlalchemy interface to allow setting a principal:

Hi @Romain,

I already have this patch in my pyhive/ file.
still impersonation is not happening and queries are not running with end user.
queries are running with the user by which hue process is running

Yes, might need to be changed to allow to propagate it.

What do you specify for the connection URL?

Hi @Romain,

I copied the above and replaced it with my file.
still the queries are not executing with end user.

This is my connection url.

options=’{“url”: “presto://xxxx:8285/hive/default”}’

Want to try ?


Thanks for this suggestion. I applied this patch on 4.6 version manually and now impersonation in presto is working .
Thanks again.

1 Like